Operating Systems

We recommend using the following operating system in production.

We also provide installers for the following operating systems. Support for these operating system is experimental only and they are not generally recommended for mission critical production environments. Please use these systems in non critical deployments, labs and experiments.

Software Requirements

The following software is required for correct functioning of Web Safety. Note, if you are using the pre-configured Virtual Appliance from our site all following requirements are already satisfied.

  • Squid 3+ to act as internet proxy server. Squid web proxy project is open sourced and is available out of the box on almost all Linux distributions.
  • Apache web server (or any other web server capable of running WSGI web applications) to act as host for Web UI of Web Safety. Installation package of Web Safety contains preconfigured deployment configuration for Apache web server running on CentOS 7, Debian 9 and Ubuntu 18.
  • Python programming language version 3.6+ which is usually directly available on all supported operating systems. Python Django 2.1 web framework for correct functioning of Web UI.