Build Squid 3.5.19 on Ubuntu 14 Trusty

Danger

This howto is now obsolete. It is recommended to use the Ubuntu 16 with latest Squid 3.5.

The following steps show how to rebuild Squid proxy capable of HTTPS filtering and SSL inspection on Ubuntu 14 Trusty.