Step 0: Preinstallation Requirements

This step is only needed if you are running Web Safety on Raspbian 10 Buster. If you are using it on Debian 10 x86_64 please ignore what is written on this page and just continue to the next step.

  1. Enable sources in /etc/apt/sources.list. This is needed for successful recompilation of Squid.

    ../../../_images/apt-sources1.png ../../../_images/apt-sources2.png
  2. Increase the swap size - make it at least 4Gb as explained in http://raspberrypi.stackexchange.com/questions/70/how-to-set-up-swap-space or https://pimylifeup.com/raspberry-pi-swap-file/

Now continue to Step 1.