Install a new version of Web Safety

If you are currently using virtual appliance (VA) the best way to upgrade is to first export configuration from old VA as described on the previous step, get a new VA from our site, import the settings into the new VA as described on the next step and only when you are sure the new VA works as expected, decomission the old VA. This will let you go back to a proved working solution in case something gets wrong!

If you are not using the virtual appliance and your proxy is running on real hardware you now need to manually uninstall old version of Web Safety.

  • For Web Safety <= 4.9 run dpkg --remove qlproxy && dpkg --purge qlproxy (Debian/Ubuntu) or rpm -e qlproxy (RedHat/CentOS). Do not forget to clear or copy to some temporary location the /opt/qlproxy folder afterwards.
  • For Web Safety >= 5.0 run dpkg --remove websafety && dpkg --purge websafety (Debian/Ubuntu) or rpm -e websafety (RedHat/CentOS). Do not forget to clear or copy to some temporary location the /opt/websafety folder afterwards.
  • Finally install latest version of Web Safety according to instructions for specific operating systems Installation and Removal. Please note there might be some changes in the required version of Django web framework or some other Python modules. Please carefully study every step of the installation script.